URGENT: Pinterest bots are slowing down my server.

cosmiquestudio
Just visiting

Hi,

I am using Wordpress / Woocommerce and Pinterest plugin for pinterest connection.

For the last 1 week, pinterest bots have been making a heavy entrance to my site and the CPU is running at 100%. CPU is running between 10-20% when I block Pinterest bots via cloudflare. We tested this with the technical team several times, Pinterest bots send 500 requests to my site in 1 minute and tire the system. The server crashed twice. So I had to specifically block pinterest bots.

Pinterest Verified Merchant Status says "Need attention" for the catalog.Could Pinterest bots be crawling my site to link the catalog? Could my catalog be disabled because I blocked them?

This is the first time I have such a problem. I do not know why it happened. I need to solve this problem urgently.

0 Kudos
6 Replies
michaelbliss
Pinterest Pioneer
Pinterest Pioneer

Hi @cosmiquestudio! Welcome to the PBC! It seems you should be able to rate limit or at least delay the crawler. Have you reached out to support yet?

0 Kudos
cosmiquestudio
Just visiting

Yes, I sent them an email. Usually take 1 week to respond. I am still waiting.

1 Kudo
michaelbliss
Pinterest Pioneer
Pinterest Pioneer

@cosmiquestudio  If you're self hosting, I believe you could use mod_rewrite to slow the crawler down depending on the software. Just an idea.

0 Kudos
PinterestDebora
Moderator
Moderator

Hi @cosmiquestudio, I completely understand your frustration. I can see that you've opened up a ticket with our support team regarding the issue. Please continue working with that team on this as they partner closely with engineering who has the ability to diagnose any issues with Pinterest accounts. I wish there was more I could do here but the teams who work on your ticket are closer to the work being done to resolve your concern. Let me know how it works out!

  Did my response answer your question? Be sure to select "Accept as Solution" to help other community members on the PBC.



0 Kudos
KawaiiFashionShop
New member

So has your problem been solved?

I have the same problem now, I keep upgrading my VPS, but it still doesn't work, the pinterest bot is making 4 requests per second, my VPS CPU is always at 100%

0 Kudos
PinterestSusana
Moderator
Moderator

Hi @KawaiiFashionShop and welcome to the PBC!

You can restrict the Pinterest Crawler by setting a crawl delay on robots.txt file of your main domain (we currently do not support robots.txt files on subdomains). You can use the following code:

user-agent: Pinterestbot

Crawl-delay: 0.2

We honor delays up to 1. If you need a larger crawler delay, please get in contact with our support team by filing a ticket. You can find more about the Pinterest Crawler here.

I hope this helps!

  Did my response answer your question? Be sure to select "Accept as Solution" to help other community members on the PBC.



0 Kudos