cancel
Showing results for 
Search instead for 
Did you mean: 

500 internal server error when validating rich pins

SparkMyDevelopment
New member

So I keep getting a ''500 internal server error'' when trying to upload an image from a link of my website to a pin and the same happens when trying to validate rich pins for my account.

Any help would be greatly appreciated as the Pinterest support gave very vague info and then told me that there's nothing I can do.

I also contacted my domain host, but they said that there was nothing wrong on their part.

Please help!

Reply
0 Kudos
4 Replies
MyHeroJoshuaF
New member

I had this. I took out the first part (https://) and it worked.

Reply
0 Kudos
Reply
Loading...
acolorfuldayp
New member

Hi!  I am having the same problem.  Did you get an answer out of here?  If I find any solution I promise share with you.

I contacted my hosting service and they said they can´t do anything.  Now I am waiting Pinterest support answer.

I tried with the solution appear down but no solve this issue for me.

Reply
0 Kudos
Reply
Loading...
PinterestRenato
Moderator
Moderator

Hi everyone, 

@MyHeroJoshuaF thank you for sharing the solution that worked out for you!

@SparkMyDevelopment and @acolorfuldayp have you had the chance to try it? Could you please confirm if this workaround also worked out for you?

Thanks!

 

**If my reply helped you please mark it as the "Accepted Solution". Need help with an account-specific question? PM me!
Reply
1 Kudo
Reply
Loading...
acolorfuldayp
New member

Hi @PinterestRenato !  I dont know if for @SparkMyDevelopment this work but I tried with @MyHeroJoshuaF recommendation and this not worked for me. 

I was searching in the web and I found someone with similar situation and the issue was produced by the SG-Worker from Cloudflare CDN that I use with my hosting service SiteGround.

I asked for the deactivation of the SG -Worker service I had and for me this was the solution.

I leave here the link of the similar case I found in the web and helped me to fiind my solution https://community.cloudflare.com/t/cloudflare-cdn-for-siteground-preventing-pinterest-from-pulling-m...

UPDATE - I was facing again this issue and I contacted SiteGround support.  I explained them the situation, the last solution I applied and attached a screenshot of the message in Pinterest Debugger and the link for Pinterest Rich Pin validator.  Then, they make another correction to the SG Optimizer Plugin and SG Worker and is working again. 

Reply
0 Kudos
Reply
Loading...